查看: 605|回复: 0

[RouterOS] Scheduler-计划任务基本信息

[复制链接]

主题

好友

567

积分

中尉

签到天数: 35 天

[LV.5]常住居民I

发表于 2016-8-9 17:10 |显示全部楼层
Anywlan微信公众号
基本信息1 H1 M2 {& v2 w: }4 x7 i) \4 H
设定的计划任务,并通过时间安排执行相应的脚本操作.& Q9 H5 V1 Y$ U. t
规格
. D1 M4 Z) T# J1 S2 F功能包需求: system
! ~" M! K! g7 J3 T; Y3 {等级需求: Level1
' S' }. C$ \; X6 Z操作路径: /system scheduler/ R/ s, U8 v$ @' H+ Q4 ~7 B
技术与标准: None# [, e0 U' T3 S" Z, c' l; K/ T  H: r
硬件使用: Not significant) w2 h0 z- u% z+ ]. U
计划表配置
7 B% |# T# u' V' T  s: }8 k计划表能触发脚本执行,在指定的时间段或者是在指定的时间间隔.* T7 X- l2 f& J* B. C, G& x/ V
属性描述& f1 P1 I5 a! T1 W8 ^# R! [" y
interval (time; 默认: 0s) - 脚本执行的间隔时间,脚本反复执行在一个指定的时间间隔+ X  C2 s- g+ a: X
name (name) – 任务名; d( @$ H6 S5 @0 E- e3 y; s$ h
on-event (name) – 脚本执行名。通过调用/system script里的脚本规则名称
5 g* ^& J* w0 J4 crun-count (read-only: integer) – 监视脚本使用数, 这个计数器记录当每个脚本执行一次,计数器便增加1
6 H" ]& u) ?$ U, ~' c: e/ Xstart-date (date) – 开始脚本执行的日期
& Y0 O. B8 O0 H8 u* Z5 D3 ystart-time (time) – 开始脚本执行的时间
& k! @5 m! j3 G" o9 j2 p9 }1 p# L% F" istartup – 默认在系统启动3秒后执行脚本.
; ]" q  w  B& n& D注:重启路由器时将重置run-count 计数器。$ @: ?* s4 {; A: [; {
如果计划表选项里面对start-time设置了startup,则在控制台开启后3秒运行。这意味着所有的脚本设置为start-time=startup 和interval=0,当路由器启动就会被执行。% m% X8 U% {9 V3 N" x4 }; z# s
事例
- o  L9 u3 j7 |: _! e我们添加一个任务执行系统日志记录测试,并间隔1小时执行一次,这个操作为logtest:
) {5 W& J. e2 e+ w" n8 V
[admin@MikroTik] system script> add name=logtest source=:log info “test”
[admin@MikroTik] system script> print
     0   name="script1" owner="admin"
     policy=ftp,reboot,read,write,policy,test,winbox,password,sniff
     last-started=may/16/2008 21:32:51 run-count=3 source=:log info " test"
[admin@MikroTik] system script> .. scheduler
[admin@MikroTik] system scheduler> add name=run-1h interval=1h on-event=logtest
[admin@MikroTik] system scheduler> print
) t( N6 y, C' G
Flags: X - disabled
#   NAME      ON-EVENT  START-DATE  START-TIME INTERVAL     RUN-COUNT
0   run-1h    logtest   mar/30/2004 06:11:35   1h           0
[admin@MikroTik] system scheduler>

; x$ J2 {; |0 _- B' s


3 c' W3 @1 q2 E0 o* x# A

/ h: N/ a/ B0 m# p1 q; {. }7 H
您需要登录后才可以回帖 登录 | 我要加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图

GMT+8, 2017-9-24 00:19

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表