查看: 237|回复: 2

[RouterOS] 动态网站解析

[复制链接]

主题

好友

567

积分

中尉

签到天数: 35 天

[LV.5]常住居民I

发表于 2016-8-12 16:59 |显示全部楼层
Anywlan微信公众号
当我们需要对某些网站进行监控或者限制访问时,我们需要得到他们的IP地址,但有时候网站的IP地址随时在变化,为了获得准确的网站IP地址我们可以通过脚本解析网站,并将它们存入地址列表
7 D  K. V. {0 |% C* j脚本如下8 m% c4 R  L+ P0 C9 P( `! }
:global a [:resolve netbar.qq.com]) m" _* g# I- D3 F# A. D
- }5 |! T9 i6 q- c: b3 S5 Z
:global b 00 ]- @/ L2 y7 c; E5 p+ g/ _" T1 z& J
:foreach i in=[/ip firewall address-list find list=qqgame] do={
* t. a/ Z2 B# ]1 V2 |% S! |/ Y$ p$ T1 f% G8 k; U" q( r
   :if ($a = [/ip firewall address-list get $i address ]) do={. s& i" W" N" ?( N
    :set b 1
: W; S, i7 c8 B- [5 q$ X# E: Y}
5 Z9 A5 t  v2 f  V, f. k$ h  M}
: j- k# l7 A4 s( ~% k4 ^( {:if ($b = 0) do={ /ip firewall address-list add list=qqgame address=$a
. _: E8 G0 K" o. {+ k. w0 s, ]8 R/ P: K" {8 c; C+ `& J, g
这里使用了resolve指令,即解析指令,解析一个网站netbar.qq.com(注:要求路由的ip dns setting里的DNS已经正确设置)
" x3 d9 m+ \0 }& l8 U通过解析后将值赋给全局变量“a”,通过foreach指令查找qqgame地址列表下的IP地址是否有相同,如果相同变量“b”设置为1,否则b设置为0。2 x4 G* a+ k  T5 m; e# m9 b
如果b值为0,即与qqgame地址列表的IP地址不同,则添加到qqgame地址列表中
$ @" O; y1 W; ?5 F0 }9 I' m; J我们将脚本添加到计划任务中/ |. I* B! E- U% r, Q( D, u

, _# k9 @, x; S9 }  N$ v" J- d! tName:我们取名为arp,区别其他计划任务规则
1 D; I, g6 E( `8 ]Interval:间隔执行时间,我们定义每间隔1分钟执行一次,你也可以根据情况自行调整,建议不要太频繁。
9 N% ^+ g* ]# z5 YOn-Event:为脚本编写框,填写执行的脚本) T: }% W( R2 Q
Policy:执行脚本的权限,默认是没有设置的,需要定义
& ?+ P1 q* U" \2 {/ l
6 b# I# d9 c& d0 D8 {" F

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?加入

x

主题

好友

1万

积分

上校

签到天数: 1610 天

[LV.Master]伴坛终老

发表于 2016-8-12 18:31 |显示全部楼层
太复杂太强大了。
回复

使用道具 举报

主题

好友

7106

积分

中校

签到天数: 530 天

[LV.9]以坛为家II

发表于 2016-8-12 20:17 |显示全部楼层
截图的是什么啊
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图

GMT+8, 2018-5-24 00:55

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表