查看: 593|回复: 0

[RouterOS] Scheduler-计划任务基本信息

[复制链接]

主题

好友

566

积分

中尉

签到天数: 35 天

[LV.5]常住居民I

发表于 2016-8-15 17:32 |显示全部楼层
TG-NET
Anywlan微信公众号
基本信息
0 N! {! E) A3 T  A设定的计划任务,并通过时间安排执行相应的脚本操作.
8 R, q  F. m- I* Y" H: b; h规格
0 o0 y4 x( h9 e+ `2 l功能包需求: system+ k  b# i1 P6 {, c
等级需求: Level1
! r( ]8 F. E# e6 T操作路径: /system scheduler
; ^8 s" w% l4 b' @. Q) n技术与标准: None
" ^" a- y# K+ x7 C4 ]+ j+ u硬件使用: Not significant$ L0 n- t2 E2 y7 d+ _3 I$ o; \
计划表配置% p( g& X. Y$ w* T- v7 v2 K
计划表能触发脚本执行,在指定的时间段或者是在指定的时间间隔.5 A+ @8 E5 Q' h# \# k: f( X( \
属性描述5 [  P+ {) @& l& g7 F" j2 G% n
interval (time; 默认: 0s) - 脚本执行的间隔时间,脚本反复执行在一个指定的时间间隔* k8 \- T( ]7 P% `
name (name) – 任务名7 d/ i6 ?; g. k9 T! M
on-event (name) – 脚本执行名。通过调用/system script里的脚本规则名称
9 ]( F* b9 F8 p9 k# g* f- h# {0 e4 g1 grun-count (read-only: integer) – 监视脚本使用数, 这个计数器记录当每个脚本执行一次,计数器便增加16 Q3 y) o" }1 u* N) u( t$ ]  b) {
start-date (date) – 开始脚本执行的日期9 u9 m9 [2 y  |7 D( J1 ?
start-time (time) – 开始脚本执行的时间) ]: d  V# h" t, \: Z; Q6 V7 p
startup – 默认在系统启动3秒后执行脚本.
0 n7 ~- G' B& g$ i* t2 m注:重启路由器时将重置run-count 计数器。: \6 ?6 N1 }% C$ t3 f
如果计划表选项里面对start-time设置了startup,则在控制台开启后3秒运行。这意味着所有的脚本设置为start-time=startup 和interval=0,当路由器启动就会被执行。2 U: M& E; B6 O. `" \
事例
) _9 z$ I; H0 X4 E, n) W我们添加一个任务执行系统日志记录测试,并间隔1小时执行一次,这个操作为logtest:
[admin@MikroTik] system script> add name=logtest source=:log info “test”
[admin@MikroTik] system script> print
     0   name="script1" owner="admin"
     policy=ftp,reboot,read,write,policy,test,winbox,password,sniff
     last-started=may/16/2008 21:32:51 run-count=3 source=:log info " test"
[admin@MikroTik] system script> .. scheduler
[admin@MikroTik] system scheduler> add name=run-1h interval=1h on-event=logtest
[admin@MikroTik] system scheduler> print

( J3 G6 P' F6 y. G6 I
Flags: X - disabled
#   NAME      ON-EVENT  START-DATE  START-TIME INTERVAL     RUN-COUNT
0   run-1h    logtest   mar/30/2004 06:11:35   1h           0
[admin@MikroTik] system scheduler>
- _( i- T8 Y0 d" |/ ^. x( {


( X* {- q2 D7 V0 u' L7 o5 V1 o1 k

9 m( u6 ]$ W2 ?1 @( y+ D6 X2 O
您需要登录后才可以回帖 登录 | 我要加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图    小黑屋 | 免责声明

GMT+8, 2017-1-21 02:00

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表