查看: 225|回复: 4

[RouterOS] DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

[复制链接]

主题

好友

566

积分

中尉

签到天数: 35 天

[LV.5]常住居民I

发表于 2016-8-18 19:55 |显示全部楼层
TG-NET
Anywlan微信公众号

一、花生壳, S0 @; B( Z& r3 j  s1 H/ h. l
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
/ F5 P% b1 |9 \( m& @0 [8 L5 R4 Y8 L现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
  N. G) d7 P8 o- m  y0 c; W7 wlocal server “http://ddns.oray.com
( r  y" s& _) f- X1 M, |local domain “域名”
' d: c/ z* P+ d( U0 X% ^3 s6 Ulocal par “/ph/update?&hostname=$domain&myip=$ipaddr”  C0 K" w8 M" k
local users “用户”) L1 k1 n; ?5 \/ N% z+ r% N" t
local paswd “密码”, p; n. K" m, k- E4 f4 {3 w- e6 [+ @
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
9 ?0 M/ T6 l& Y' ~' D:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]( n6 ~$ M$ A8 [* [; I
/tool fetch url=($server . $par) mode=http user=$users password=$paswd
. N  ], X! R) _5 |) M
/ `( s5 M6 ?+ [/ ]4 j+ |" A

二、3322

脚本:

* v+ G! o" R6 x2 d
:local ednsuser “用户”' Y, B* M" C! y5 g: G$ [5 e
:local ednspass “密码”
) H* R; e% c1 q* i- h4 S5 x4 T( X:local ednshost “域名”
/ i: c3 W2 z5 W0 V) N( q4 H:local ednsinterface “接口”5 V9 z7 X* b2 Y! a7 \
:local members “http://members.3322.org/dyndns/update?system=dyndns
3 X, U: N0 z; t% @* ?5 H#:local members “http://members./nic/update?”  Z* p7 b3 G: u" i' r1 H
:local status
* O8 i; p4 a- X- a:local status [/interface get [/interface find name=$ednsinterface] running]2 k* ]! i+ Z* |# Z- Q5 k+ D2 v
:if ($status!=false) do={, @2 h/ ]+ R- r# Z6 `4 A% B
:local ednslastip [:resolve $ednshost]2 U) n5 u% j6 U8 a9 P* x; R) L! J
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
) e! O5 L% z' S# V/ h3 M6 Z:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]1 k. `2 P) F, U
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]& z0 T, K( I( o: O+ r& j$ P1 s7 f
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
2 U% N2 f6 O; a3 G% R/ O9 D:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost/ Y) }5 o% E  N8 F( d' K/ j& v
:delay 2
( l0 k; W$ p$ W' j7 c+ M:local result [/file get $ednshost contents]
. u6 `4 X. Y* D:log info ($ednshost . ” ” .$result)
) ]" ?( j( b9 d. h' Q* A/file remove $ednshost ;
( Y1 P: T- B2 H# w* T- d}% q5 V" F% M, e9 _- _
}

, _, d! {- o2 J6 j" ]2 |
, h  @0 i. |8 Z; |
/ A2 d, F) V, T6 A8 z4 _4 [

主题

好友

2068

积分

少校

签到天数: 13 天

[LV.3]偶尔看看II

发表于 2016-8-18 20:20 |显示全部楼层
个人实测还是3322稳定些  遇到很多次花生壳解析不稳定情况
回复

使用道具 举报

主题

好友

2917

积分

少校

签到天数: 261 天

[LV.8]以坛为家I

发表于 2016-8-18 20:39 |显示全部楼层
zhl416 发表于 2016-8-18 20:20
  U2 p; @% _4 `+ q# k个人实测还是3322稳定些  遇到很多次花生壳解析不稳定情况
6 B7 G) r6 V& l' x6 A' z0 p0 O' S
给钱就稳定。。。。。
回复

使用道具 举报

主题

好友

1万

积分

上校

签到天数: 699 天

[LV.9]以坛为家II

发表于 2016-8-18 21:06 |显示全部楼层
18960601773 发表于 2016-8-18 20:392 t/ n% j7 ^% @( `: ^
给钱就稳定。。。。。

. x5 V: i2 w# `, U2 D4 h, k# a  W$ I4 t/ ^5 g3 R
所言甚是+言之有理
回复

使用道具 举报

主题

好友

18

积分

新兵上阵

签到天数: 1 天

[LV.1]初来乍到

发表于 2016-8-21 12:56 |显示全部楼层
很好,非常有用
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 我要加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图    小黑屋 | 免责声明

GMT+8, 2017-1-18 07:26

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表