查看: 369|回复: 0

[RouterOS] 无线Nstreme配置

[复制链接]

主题

好友

564

积分

中尉

签到天数: 35 天

[LV.5]常住居民I

发表于 2016-9-8 17:25 |显示全部楼层
TG-NET
Anywlan微信公众号
本帖最后由 用易-小卢 于 2016-9-8 17:30 编辑
$ X# L- i. `- q6 U" `/ N& F
3 x+ L0 ?. c* _! u3 \: f
Nstreme 点对点高带宽设置
Nstreme 是 RouterOS 独有的协议,支持数据帧重组,提高 WLAN 无线传输带宽,使用 Nstreme 特别依赖CPU性能,如果采用 RB433AH 在5G-turbo 模式下可以获得70Mbps的带宽。注意:Nstreme 不支持 ap-bridge 对 ap-bridge 的模式
点我们可以采用 ap-bridge 或者 birdge 方式,在这里我们推荐使用 ap-bridge 与 station-wds 的桥接方式,如下图:

$ s% \, C/ d+ b0 o2 C

% T. ^. R9 k4 ]8 R: O6 q' a
设置在ap-bridge和station-wds模式的我们分以下步骤:

    , K  r: y) M, o& |' X1 j( c! `
  • 在 ap-bridge和 station-wds 中添加 bridge,定义 bridge 的接口,并分配管理的 IP 地址
  • 配置 ap-bridge 和 station-wds 的无线参数
  • 检查桥接连接情况 3 S% M  M' [9 U* K# d0 K' G
步骤1:进入bridge添加bridge1的桥接,通常情况下我会开启rstp协议,启用生成树协议:
添加 ether1 和 wlan1到 brdige1 桥接中,这里在 interface 中分别添加 ether1 和 wlan1 进入bridge1 中。这样 ether1 和 wlan1 就实现了桥接功能,能实现数据二层的透明传输:
/ Y9 o8 K7 f. V: _2 u1 U
+ N5 d# c: ^6 s' ?% A- b
" i' N7 w* \: O( W9 ~: A9 a: ]9 i& N& X% V9 }1 L6 X
注:在RouterOS3.0的bridge中增加了一个设置选项,是否选择 ip firewall 过滤,如果不使用 ip firewall 过滤路由器的桥接转发速度将提升性能,但如果你要求对无线传输过程中的IP数据进行过滤处理,那就需要开启 use-ip-firewall 功能:+ O6 e" o: w' L  k, I& {
9 ~. [  {* M  v& \: L- u, u6 g
5 r6 w4 |: U' |- u6 R# e6 q
:以上配置操作适用于 ap-bridge 和station-wds设备
设置完桥接后我们进入 ip address 给 ap-bridge 和 station-wds 的 bridge 配置一个IP地址 192.168.10.1/24 和 192.168.10.2/24,用于管理设备和监测用。这样 wlan1 口和 ether1 都能分配到这个地址。命令如下:
ap-bridge设备
/ip address add address=192.168.10.1/24 interface=bridge1
station-wds设备
/ip address add address=192.168.10.2/24 interface=bridge1
步骤2:桥接和IP地址设置好后,现在配置ap-bridge和station-wds的无线参数。
设置ap-bridge的无线,这里mode=ap-bridge,band=5G,frequency=5200,SSID=CDNAT
7 [8 I0 d1 [: r' z: ^, |
; h) P; ?3 s, @% L; J: L, }

, G4 L3 J3 R; p; Z
配置 ap-bridge 的 WDS 模式,配置参数 wds-mode=dynamic-mesh(动态方式),wds-defaultBridge=bridge1(将连接无线添加到bridge中)
/ X; _! }* ^/ G- H8 F
2 d5 W' M6 o' `7 i7 k
  O1 E5 p1 g! X$ R配置 station-wds 端的设置只需要将Mode=station-wds band=5G,SSID=CDNAT,不需要设置 Frequency 参数,station-wds 在匹配 Band 和 SSID 后会自动搜索:* e2 w, u( ~4 Z& ~
7 \+ K( o6 J) F2 s' m! G$ P! K% w4 }
在 station-wds 模式下与 ap-bridge 的WDS参数配置相同
. }( k4 B, o( m% c6 l% f3 [' a/ A9 C
: Z: H* l- D7 G$ g2 a& R步骤3:当配置完成后,我们可以通过在 ap-brdige 端的设备查看是否连接,如果正常连接后 ap-bridge 端的 Wireless Tables 下会在 wlan1 前现时“R”,并增加一个wds1 的无线接口。8 v0 @6 I) u1 j/ v4 O1 F7 ^
- C" f" p* ^2 ]

5 M4 K' |( I$ _7 Q- D在ap-bridge 下的 Bridge 中可以看到,WDS 模式自动将 wds1 接口添加到Port 中:$ ?/ T0 W' M& ]  S+ m7 r/ c

' q) \( Y( }) t- n5 s  i3 t6 w5 V' K' Y! v9 l' h
我们可以通过在无线注册信息列表中查看信号强度:& q2 V! H& O' ^4 a& w* m! D

  X; J% A1 {# S
. q7 |5 N4 J' \这里显示的是-63,信号能连接使用的最低值在“-88到-90”,数字越接近正数“1”信号越强。Station-wds端在连接后会自动适用 ap-bridge 的参数,并正常通信。
& d' j2 O0 e) N/ B启用Nstreme协议MikroTik 都有的 Nstreme 协议用于长距离的无线传输、增加带宽和提高网络质量的作用。 Nstreme 只支持 ap-bridge to station/station-wds,不支持 ap-bridge to ap-bridge,所以通常 Nstreme 被用于点对点传输或点对多点传输。启用 Nstreme 的操作只需要进入无线网卡配置的 Nstreme 选项。
; Y6 B. [9 ~) a9 m) N
1 o! {/ e0 h* M7 m: G- M3 v" j4 P' m在我们做点对点传输的时候,可以启用 Nsteme 协议,提高网络安全和传输质量。Ap-bridge 的配置,启用 Nsteme 协议,禁止 CSMA 协议,并选择最好的帧传输:! E8 I. s. s; `. Y( v5 y
9 C$ Q1 }) v* I- `( U% y

+ ]" O7 e2 G0 J# ~( j+ H2 iStation 和 station-wds 的配置,只需要启用即可:! |! A( ~" s; I! ~

: W& g/ g* ~; W0 C: Q9 \# m! F
. U. S* q8 U3 e& c# W
0 U- M; |$ v, ^+ K0 i- h
$ W7 S7 ]$ K. y& i  w/ n5 X/ T- Y8 M% o
您需要登录后才可以回帖 登录 | 我要加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图    小黑屋 | 免责声明

GMT+8, 2016-12-8 06:21

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表