查看: 451|回复: 5

[OpenWRT] TL-WR941N V5刷OP可以从breed直接刷吗?

[复制链接]

主题

好友

6783

积分

中校

签到天数: 1134 天

[LV.10]以坛为家III

发表于 2016-9-8 23:44 |显示全部楼层
TG-NET
Anywlan微信公众号
TL-WR941N V5已刷不死BREED,现在要刷明月OP,可以直接刷吗?

网络搜索下,以下方法太复杂啊。下面内容高人勿视,是网络复制过来的。







刷机有风险,需谨慎!
这里列出本文作为演示的路由器的版本:

TP-LINK TL-WR941N Ver 5.1
理论上Ver 4.0以及TL-WR941ND也可以使用本文提供的资源
其他型号勿用!
了解了你的路由器之后,你便可以和我一起开始激动人心的刷机进程了
刷入DD-WRT在刷入OPENWRT之前,我们必须先刷入DD-WRT
1、前往DD-WRT官网搜索你的路由器型号:http://www.dd-wrt.com/site/support/router-database
若找不到你的型号,切勿继续!
若你和我使用一样的路由器,直接下载下面的包:
109262081
点此下载(TL-WR941N(D) V4/V5 DDWRT包)
文件大小:未知

2、完成包的下载后,输入192.168.1.1进入你的路由管理界面,进入软件升级界面,选择刚才的包进行升级
注意:升级前务必确认包的正确性!且保证电源稳定,不可断电!

3、点击“升级”按钮,路由器会自动安装升级包,完成后会自动重启

4、等待路由器启动完成,若你使用WIFI连接到路由,这时会出现一个叫dd-wrt的WIFI网络,连接上它

5、再次输入192.168.1.1,即可进入DD-WRT的管理界面,首次进入会被要求设定用户名密码,设定即可


6、接下来进入Administration,有一个语言选项,切换为简体中文
若你要刷的是DD-WRT,那么刷机过程就完成了,恭喜你,刷机成功!只需要配置好无线和ISP信息就可以用啦!
刷入OPENWRT若你要刷入OPENWRT,先要完成上面的步骤,然后继续跟我走,困难的才刚刚开始,另外,建议你有一些Linux基础再继续,否则你可能遇到很多困难
1、前往OPENWRT官网下载适合你的路由器的包:http://downloads.openwrt.org/snapshots/trunk/
若你使用和我一样的路由,可以直接下载下面的包:
109262243
点此下载(TL-WR941N(D) V4/V5 OPENWRT包)
文件大小:未知


1、进入DD-WRT的服务选项,打开SSHD服务,其它选项不要动,保存并应用
2、用WinSCP连接到你的路由器,具体信息如下
IP:192.168.1.1
用户名:root
密码:你设置的Web管理密码
3、接着将上面的包传到tmp目录下
正常路由器应该使用上面斜体字的方法,可是TL-WR941N的DD-WRT似乎有BUG,无法启动SSH,于是只能使用下面的备用方案:

1、将上面的bin文件传到百度云网盘上
2、从百度云下载这个文件,复制文件链接
3、在CMD窗口下输入下面的命令:
                                         











MS DOS


telnet 192.168.1.1
1

telnet 192.168.1.1



若提示命令不存在,请在控制面板中添加删除程序添加telnet服务器
4、登录的用户名默认为root,密码就是你web管理的密码
5、登录成功后会出现欢迎界面

6、输入下面的命令,下载bin包
                                         











Shell


cd /tmp/wget 百度云下载链接(短时间内有效)
1
2

cd /tmp/
wget 百度云下载链接(短时间内有效)



7、成功下载bin包,达到上传目的

2、不论你使用上面的哪种方案,最终都把bin包放到了路由器的tmp目录内,接下来进行刷机工作
3、使用方案二的方法登录路由器的telnet,然后输入下面的命令开始刷机
                 
                        











Shell


cd /tmp/mtd -r write 刷机包名称.bin linux

1
2

cd /tmp/
mtd -r write 刷机包名称.bin linux




4、输入命令后刷机会自动开始,约1分钟后,telnet连接便会断开,路由器自动重启

5、若选择的刷机包没有错误,那么路由器会自动启动到OPENWRT系统,但是OPENWRT系统默认没有打开无线功能,所以我们只能通过有线端口连接到路由器
6、用网线连接路由器后,由于OPENWRT默认没有图形化界面,所以我们现在只能使用命令行进行配置,打开CMD,输入下面的命令
                 
                        











MS DOS


telnet 192.168.1.1

1

telnet 192.168.1.1




7、若路由器正常工作,则会出现OPENWRT的欢迎界面

8、输入下面的命令,修改无线网络设置
                 
                        











Shell


vi /etc/config/wireless

1

vi /etc/config/wireless





                 
                        











Shell


config wifi-device radio0option type mac80211option channel 11option hwmode 11ngoption path 'pci0000:00/0000:00:00.0'option htmode HT20list ht_capab SHORT-GI-40list ht_capab TX-STBClist ht_capab RX-STBC1list ht_capab DSSS_CCK-40# REMOVE THIS LINE TO ENABLE WIFI:# option disabled 1(删除或者是注释这一行,打开无线网络功能)config wifi-ifaceoption device radio0option network lanoption mode apoption ssid OpenWrt(设置SSID)option encryption psk2 (修改为psk,即WAP加密,psk2,即WAP2加密,建议psk2)option key xxxxxxxxx(设置网络密码)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option path 'pci0000:00/0000:00:00.0'
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1(删除或者是注释这一行,打开无线网络功能)

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt(设置SSID)
option encryption psk2 (修改为psk,即WAP加密,psk2,即WAP2加密,建议psk2)
option key xxxxxxxxx(设置网络密码)




9、按照上面的设置修改配置文件后,:wq保存退出,然后输入下面的命令重启网络服务
                 
                        











Shell


/etc/init.d/network restart

1

/etc/init.d/network restart




10、接下来路由器的无线网络服务就成功启用了,若你使用pppoe上网,那么还需要设置ISP的宽带用户名密码,输入下面的命令打开编辑
                 
                        











Shell


vi /etc/config/network

1

vi /etc/config/network




11、找到config interface ‘wan’部分,按照下面提示修改,没有的需要添加
                 
                        











Shell


config interface 'wan'option ifname 'eth1'option proto pppoe(即PPPOE模式上网)option username 1234567(ISP用户名)option password 7654321(ISP密码)

1
2
3
4
5

config interface 'wan'
option ifname 'eth1'
option proto pppoe(即PPPOE模式上网)
option username 1234567(ISP用户名)
option password 7654321(ISP密码)




12、同样保存退出,输入reboot重启路由器
若连接正常,配置正确,你的路由器应该能正常使用了!恭喜你,OPENWRT安装完成!
安装OPENWRT图形化管理界面完成上面的步骤后,你的OPENWRT只能使用命令行进行管理,非常不方便,所以我们需要安装图形化管理界面
1、在telnet下运行下面的命令安装LuCI Web界面
                 
                        











Shell


opkg updateopkg install luci/etc/init.d/uhttpd enable/etc/init.d/uhttpd start

1
2
3
4

opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start




2、接下来安装中文支持
                 
                        











Shell


opkg install luci-i18n-chinese

1

opkg install luci-i18n-chinese




注意:截止2016年7月24日,这个命令已经失效,新方法:http://www.wanghailin.cn/openwrt-luci-new-chinese/
3、接下来输入192.168.1.1,即可进入图形化管理界面,首次进入是没有密码的,直接按下login按钮即可
4、然后选择System-System,选择语言选项,将语言更换为Chinese

5、接下来顶部会出现一个设置密码的提示,按下去设置按钮,然后填入你的密码,SSH功能以及登录密码就会启用了,同时,telnet会被关闭,不过现在就可以通过SSH连接管理路由器啦

SSH IP:192.168.1.1
SSH端口:22
SSH用户名:root
SSH密码:你设定的密码
6、至此,图形化界面安装完成!你可以根据自己的需要自行设定,例如端口映射、无线设置等
OPENWRT设置错误恢复由于OPENWRT的强大功能,设置很容易出现错误,而且一旦导致network模块错误,就会出现无法管理的情况,这种情况提供一种紧急恢复方案(仅在TL-WR941N测试)
1、将路由器断电,再准备一根牙签,或是一支笔
2、插上路由器电源,最开始所有的灯会长亮一次,等长亮灯熄灭后,灯再一次亮起时,用牙签或笔按住路由器RESET按钮2——3秒,接着你会发现路由器最左侧的设置灯很快的不停的闪烁,这说明你已经成功进入路由器安全模式
3、用网线有线连接到路由器,然后将本地连接设为手动获取IP地址,将IP地址设为192.168.1.5,子网掩码保持默认的255.255.255.0,默认网关不填写
4、接下来再次用telnet连接到路由器
                 
                        











MS DOS


telnet 192.168.1.1

1

telnet 192.168.1.1




5、输入下面的命令,完成路由器的重设
                 
                        











Shell


firstbootreboot

1
2

firstboot
reboot




输入firstboot命令时系统会要求确认重设,输入Y即可
6、等待路由器重启,然后返回到刷入OPENWRT的第6步开始重新设置路由器
救砖成功!










主题

好友

1460

积分

上尉

签到天数: 24 天

[LV.4]偶尔看看III

发表于 2016-9-8 23:59 |显示全部楼层
直接在不死BREED里刷
回复

使用道具 举报

主题

好友

246

积分

少尉

签到天数: 3 天

[LV.2]偶尔看看I

发表于 2016-9-9 00:00 手机上Anywlan 随时随地无线:http://m.Anywlan.com |显示全部楼层
我想请问下941怎么刷入不死
回复

使用道具 举报

主题

好友

1228

积分

上尉

签到天数: 141 天

[LV.7]常住居民III

发表于 2016-9-9 08:29 |显示全部楼层
进入不死breed,然后从breed选择固件刷入
回复

使用道具 举报

主题

好友

6783

积分

中校

签到天数: 1134 天

[LV.10]以坛为家III

发表于 2016-9-9 21:34 |显示全部楼层
_打豆豆。 发表于 2016-9-9 00:00
我想请问下941怎么刷入不死

是卖家刷好的。某论坛有教程。
回复

使用道具 举报

主题

好友

6783

积分

中校

签到天数: 1134 天

[LV.10]以坛为家III

发表于 2016-9-9 21:34 |显示全部楼层
多谢各位朋友指导,这下放心刷了。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 我要加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图    小黑屋 | 免责声明

GMT+8, 2016-12-10 13:02

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表