查看: 290|回复: 0

[RouterOS] ROS 脚本。

[复制链接]

主题

好友

655

积分

中尉

签到天数: 32 天

[LV.5]常住居民I

发表于 2017-6-6 21:29 |显示全部楼层
Anywlan微信公众号
) D& f% c: ~+ Y( H" ^. ]
/system clock0 ]' @; N# W9 z
:global currenttime
  g' x1 R: H. J:set currenttime [ get time]  + U0 r8 x) D& g. t. P) g
, k& z, U4 a# e; j  M% W: V
:local hotspotcount 0
* _& B9 `% N8 b/ U: v* g: v:local hotspotcounthotspotcount 200) d& B2 |$ G7 R$ R5 c7 n) r( M
:local nl 4
7 L# P1 N; e" t8 T6 K0 c
: K& [  A. C% i& v/system license9 Q! O; o+ M4 x4 }$ V" v! E7 C
:set nl [get nlevel ]9 t5 Y% I% H* q8 f

) U6 i9 l- O5 F" {:if ($nl=4) do={:set hotspotcount 200}) y7 o* d: w4 V+ p, @4 A
:if ($nl=5) do={:set hotspotcount 420}
. ~+ Y" ^7 F1 k; l: w:if ($nl=6) do={:set hotspotcount 840}
: y0 v! t8 g3 _& A2 [  A6 p3 P: I0 x" l8 }) ?6 N, n# O! u  Y6 u8 F/ p
/ip hotspot active1 N8 D' x2 n* C5 i  x
:foreach i in=[ /ip hotspot active find  ] do={:set hotspotcount (hotspotcount+1);  }
3 [1 P, b1 K9 N8 z) F1 W+ W# d" R" U1 s, L' e1 Y6 N: C
:if (($currenttime>"1:00:00" && $currenttime <"5:30:00")|| $hotspotcount >$hotspotcount) do={
) Z$ x$ G  g% C+ Z2 G
. O' C3 U! h) Q# ^" J5 H' e/ip hotspot active
5 \; s4 |' k% I5 J  |1 e0 h:foreach i in=[ /ip hotspot active find  idle-time > 1800  ] do={ :log info message=[ get $i ] ;remove $i;:delay delay-time=1;};
5 x6 q( \; Q: [  _. U4 x& v
8 q* R* ]( Q/ {% S/ip hotspot host
: r8 j( C, J! w:foreach i in=[ /ip hotspot host find  idle-time > 1800  ] do={  :log info message=[ get $i ] ;remove $i;:delay delay-time=1;};
" w: C. \$ j6 S1 d:log info message=($currenttime." hotspot clear");$ G" n# }/ B' S7 A+ _  }7 F
& B) t% @( G) c
:if ($hotspotcount >$hotspotcount) do={, f' K( p/ m" `0 o2 ?
* Q8 N$ l! g/ T0 s. s# ?$ O
}
- J0 n- f% \% Y8 A! j# S0 T8 }1 L: Z}7 E' L; D' m4 U! G# V! s! a
: U5 o8 }0 Y7 [1 ~! @( z/ K/ s4 W
您需要登录后才可以回帖 登录 | 加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 )  |网站地图

GMT+8, 2018-4-25 14:37

Powered by Discuz! X3.2

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表