查看: 814|回复: 5

编译LEDE/Openwrt 17.01

[复制链接]

主题

好友

249

积分

少尉

签到天数: 34 天

[LV.5]常住居民I

发表于 2018-4-16 11:22 |显示全部楼层
Anywlan微信公众号
网上有很多教程编译openwrt/lede,不过我们遇到的问题不是编译本身,而是下载代码。我这里就整理了一下,把相关的代码都打包起来。大家按照我的资源来,就很容易编译了:

* 首先下载我打包的资源:链接:https://pan.baidu.com/s/1qKYUYX_ve6sJ6uXxEvV3Nw 密码:3l4y
* 安装Ubuntu 16.04 amd64,然后把资源拷进去
* 在ubuntu里面
   sudo apt -y install <一批工具>
   ./scripts/feeds install -a
   make menuconfig
   make -j1 V=s
   基本就可以编译成功了

详细过程请参考资源包中的  编译.txt

主题

好友

403

积分

少尉

签到天数: 33 天

[LV.5]常住居民I

发表于 2018-7-14 20:28 |显示全部楼层
感谢分享,我要试试
回复

使用道具 举报

主题

好友

999

积分

中尉

签到天数: 13 天

[LV.3]偶尔看看II

发表于 2018-8-2 10:24 |显示全部楼层
这个的确是好东西
回复

使用道具 举报

主题

好友

1619

积分

上尉

签到天数: 105 天

[LV.6]常住居民II

发表于 2018-8-22 16:05 |显示全部楼层
我在编译中到下载源代码这一步总是出现如下提示:
l@l-virtual-machine:~/lede$ git clone -b lede-17.01 https://git.lede-project.org/source.git
正克隆到 'source'...
remote: Counting objects: 435686, done.
remote: Compressing objects: 100% (123453/123453), done.
error: RPC failed; curl 18 transfer closed with outstanding read data remaining
fatal: The remote end hung up unexpectedly
fatal: 过早的文件结束符(EOF)
fatal: index-pack failed

请问该如何解决?
回复

使用道具 举报

主题

好友

249

积分

少尉

签到天数: 34 天

[LV.5]常住居民I

发表于 2018-9-7 15:00 |显示全部楼层
2484141958 发表于 2018-8-22 16:05
我在编译中到下载源代码这一步总是出现如下提示:
l@l-virtual-machine:~/lede$ git clone -b lede-17.01  ...

不要下载代码,就用我包里提供的
回复

使用道具 举报

主题

好友

1619

积分

上尉

签到天数: 105 天

[LV.6]常住居民II

发表于 2018-9-7 20:06 |显示全部楼层
liushengjie007 发表于 2018-9-7 15:00
不要下载代码,就用我包里提供的

谢谢!换了个网址解决了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 ) |网站地图

GMT+8, 2018-11-19 16:55

Powered by Discuz! X3.4

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表