查看: 52841|回复: 283

[RouterOS] [负载平衡] ADSL多线PCC跑下载 VPN/光纤跑上传

  [复制链接]

主题

好友

118

积分

上等兵

该用户从未签到

发表于 2010-12-4 10:27 |显示全部楼层
Anywlan微信公众号

8 t3 r' Q$ @0 P- I' K8 k3 Z
转的。。大家参考!4 P2 T6 q# {1 O4 Z4 |
- J5 }. j  a* o3 G* h

2 A& {4 f1 ~, B( x2 v% l VPN /(本地光纤)跑上传,ADSL跑下载,可以解决几个问题,第一,有效躲避某些地方ISP对ADSL共享检测(网络尖兵等),第二,本地光纤跑上传,ADSL跑下载可以解决ADSL的技术缺陷,避免ADSL由于上行带宽过小,而影响下行的问题,让网络更加流畅。第三,对光纤线路带宽占用也比较小,这样予己予人都比较合理,而不象以前的传统的VPN模式,我们1M的下载,会占用对方服务器一上一下2M带宽。第四,因为VPN技术的极高加密性,会给帮助我们解决很多问题。最后,VPN /(本地光纤)跑上传的至关重要的关键点,比如电信ADSL和本地电信光纤组合,因为出口的ADSL的IP地址和光纤是一个ISP商,验证源地址方面一般没问题,如果是借线外地的VPN SERVER就要看对方是否会验证源地址,如果要验证就没办法,只有另外寻觅VPN SERVER,很多各地方的ISP有限制,非本地的IP段是禁止转发的。另外最好是同一营运商,比如都是电信或者都是联通,这样速度才够快,否则一个联通一个电信,等你数据包到了对方VPN SERVER延迟都几百ms,那就没意义了。一般小于100ms的延迟还可以接受,当然越小越好。. g0 d9 |! R: W
2 {( y! F6 N8 t0 y3 b
: S1 V$ Y0 x' `# A
首先设置4条PPPOE拨号,我这里是光纤到楼,网线到户,一条物理线路可以多账号拨入,一个账号4M,可以通过PCC达到带宽叠加。
- \$ z6 V6 D1 W1 W# A! F+ D* Q: a" D# G/ H& S3 L

5 J. G8 \1 f6 c3 G: J( U- a/ K. R" L  y, a# t5 `. s
  u; v' V% h7 k; N% u7 N- }
, ?  a8 n5 L, u# J2 }
后面4条线路都按照此设置,有本地光纤线路的,add default route就不需要打勾,因为本地光纤是默认线路。纯ADSL环境的可以勾上,因为无论有多少条PPPOE线路,最后只有第一条拨上号的生效成为默认线路。这样就不用我们制定到底是哪条PPPOE做默认,一切交给系统决定,这样至少保证有一条能拨上号的成为默认线路,网络始终不会中断的,除非全部账号都到期,或者全部ADSL猫都坏了,那是真是平田真悲剧平男了。
. d8 p) g) K6 G9 v2 M* y/ g- D7 O& ~, ~4 c* G# a8 L( e8 \
  |7 Y* p5 T6 x5 D5 s! U
因为我家是纯PPPOE环境,我需要拨一条VPN线路来帮我逃避我本地ISP商的panabit服务器对P2P软件的屏蔽(其实这是我最终的目的,哈哈),因为VPN是高度加密的。这里推荐对方VPN SERVER使用L2TP模式,它是UDP协议,效率更高,加密性是最好的,和IPSEC一样,比PPTP加密性更高。当然PPTP也一样,我也是用的PPTP。
# _" _; O0 @+ T/ n. Z1 s
9 _- I' D1 l" l/ g8 t- f; w; Q
$ p9 o1 D1 d3 ?% n  b7 n 2 ?8 X  t) v& I! v/ _% |# G+ N; s
3 G6 P5 {/ z& Y" M: i! a' Y

: u, A9 j# i# m5 X8 a7 }5 x+ t* F' x& S3 d

) l( e% i) C; t, @. ~7 x. @" f$ l: c7 S) M5 O; _

, P0 q1 x" a+ @. I. y/ N) V: f: D; N
PCC的做法我就不再赘述,大家可以参考论坛讲PCC的帖子,有很多。
- @$ I  S8 u2 `7 H4 @  V. Y/ h7 k0 i- g5 o9 a( V' W/ f

3 Q/ }+ f& S( r) V/ ?
! L5 @% V, x+ t" w
7 o. `5 V" {  x0 `下面是设置的关键2个步骤:  v% Y9 K2 c. W
0 i- S( v; B; _. t
这是NAT里的设置,我有4条线路,就需要设置4条规则,以此类推。把我们发出去的PCC包的源地址修改成我们PPPOE的外网地址,这样最终响应端会把数据包按这个IP地址发回来,这样就上行走的VPN线路,数据包直接按我们修改后的源地址发回来。这里可能有些朋友还有些疑问不会掉线吗?我再罗嗦两句,打个生动比方由于我们本地邮局A很严格,导致我发出去的很多信件的内容它都要审查,不能通过,那我没办法只有将信件加密过后,先送到附近邮局B帮我发送,但是发信人地址我还是写的我在邮局A的收件地址,由于邮局B比较耿直,不管是外来投递还是本地投递的邮件,它都一律按照目的地址送到,对方收到我的邮件过后,就按照我在邮局A的地址把信给我回过来了,我就收到了对方的回信然后和组织联系上了,邮局B就是借了个道而已,但是一定要注意邮局B要允许外来投递的信件噢。% |3 h/ z, u$ V. V4 b4 l

/ R6 H) s2 ]$ z7 a! G( K. v7 A  t8 n, i# F' l/ q
$ q, H9 o. Y. f% J3 L; F

1 ~  c& T; B0 J) e% `& ~! l
% J3 z' Q/ _8 c- v. v# R7 G! h0 A, U+ v. h2 v9 K7 k

+ \  U5 L# m+ E4 F
0 ^+ N3 Q; z  @& N, [  \2 F下面是路由表里的设置
. X" r- ?5 H. \% e+ ~" Z1 Q  d( G4 s0 y( S* T

( N: g) e4 o, H' k# \9 p  @0 n6 i8 v, p
  L7 q% u- G6 w( D% S
5 A/ W/ i, m' u1 u
0 g1 E" D$ S! D: J7 m最后注意几个地方:new-connection-mark的名字一定要以1 2 3 4为顺序,否则脚本不能正常工作,4条mark routing的路由标记设定成同一个名称,设置完PCC后,运行该脚本,NAT里的规则脚本会自动生成。手动添加的规则标签名一定要以pppoe-out1 2 3 4为顺序。如果本地有光纤线路,作为默认线路的话,那么直接路由标记可以选择main4 R, v1 I4 o( w& o0 ?/ Z

4 M# k6 B& C! O9 D' g+ c: U动态IP自动修改脚本:6 g* B- u  t+ u" C

+ k! r2 c# D! H4 }2 A( G6 J
- {9 M8 G* a9 O8 d3 c, J{; u0 v3 @# I" s' r! j# a: O$ J3 a
:local ipa ""- k5 i8 I2 Y; s  P* V
:local ipb ""
; B) Y% s% }5 e9 e% x$ Q6 B* M& p* m:local pname ""
: G( a$ L( D7 k$ ]9 J9 y/interface pppoe-client) e$ I5 i( G8 m( D3 D$ D, h7 r
:for ii from 1 to 4 do={
" N7 B" x8 O; A7 ]:set pname ("pppoe-out". $ii)
. z% m1 Y( m4 m. A4 d) ]+ d5 Zmonitor $pname once do={
- }1 z6 ]5 ?2 ~$ b' L$ b:if ($status="connected" && $uptime<00:10:00) do={
/ M3 S* m. _- k% ~5 K& r:set ipa [/ip address get [/ip address find interface=$pname dynamic=yes] address]
! r( ^: B/ j) V- D4 j8 t:set ipa [:pick $ipa 0 [:find $ipa "/"]]
. G) t( Z6 B( B1 K6 }:if ([:len [/ip fir nat find connection-mark=$ii]] > 0) do={/ P# }; R, t$ W$ ^* i8 n
:set ipb [/ip fir nat get [/ip fir nat find connection-mark=$ii] to-addresses]
9 a8 T  U! S1 J/ `/ z} else={/ip fir nat add action=src-nat chain=srcnat connection-mark=$ii to-addresses=$ipa comment=$pname;:set ipb $ipa}
/ a! O$ X2 Y; G5 F, Q:if ($ipb != $ipa) do={
" m+ _* X) l- `" \/ip fir nat set [find connection-mark=$ii] to-addresses=$ipa disabled=no7 O8 v6 A3 Z8 X; k8 }+ {% ]4 a' f
:log warning ("\D0\DE\B8\C4\5B" . $pname . "\5D\D3\B3\C9\E4\B5\BD" . $ipa)
8 {; X$ ]7 z  K/ e! f:beep length=3000ms frequency=1800
4 @7 G2 k; g0 t" s/ s7 Q}}}}}
. g: p  h3 N4 U. f# V+ J( R: {( K( B

. T+ ^0 h3 W; ~
+ l& R. `' a6 h/ A0 [% w7 i注意红色部分,有几条线就改成几的阿拉伯数字
2 _/ T- y: ]/ l7 I8 f2 R) _/ L7 |3 o7 c
再加上我的DDNS更新脚本,自动找到默认线路后更新IP8 n8 x- t) d5 y: v

6 ?  e3 X! H8 \1 g7 l- F3 W" h7 J) Y{
) [9 X5 B% n$ n4 G:local ddnsint [/ip route get [/ip route find dst-address=0.0.0.0/0 dynamic=yes active=yes] interface]6 H& N' G: p" n% h! Z- D
:local ddnsip [/ip address get [/ip address find dynamic=yes interface=$ddnsint] address]$ H' M* q3 }! h1 V( O( ?
:local ddnsnip [:pick $ddnsip 0 [:find $ddnsip "/"]]
+ q9 Q  e% a( F' Z) G/ O:if ($ddnsnip != [:resolve "xxx.25u.com"]) do={- \8 d: T  C- ?# z
    :log info [/tool dns-update name=xxx.25u.com address=$ddnsnip key-name=xxx key=xxx]* S) I5 |- O/ T
}}, v8 n* s8 H9 J+ B5 C
; L) |5 V! L/ U2 K& J" W$ f# h
  G# N6 d4 s& b# o! n+ G

# ^# A- c; c  Y: t- j
5 [6 H) |; h7 M; `所有设置和测试均在3.30版本上通过。最后,如果教程有不当之处,或者有更好,更科学,可以改进的地方,请大家指出斧正,请跟贴

评分

1

查看全部评分

头像被屏蔽

主题

好友

1000

积分

禁止发言

签到天数: 23 天

[LV.4]偶尔看看III

发表于 2016-7-19 17:29 |显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复

使用道具 举报

主题

好友

1571

积分

上尉

签到天数: 1 天

[LV.1]初来乍到

发表于 2010-12-4 11:44 |显示全部楼层
dddddddddddddddddddd
回复

使用道具 举报

主题

好友

1594

积分

上尉

签到天数: 1 天

[LV.1]初来乍到

发表于 2010-12-4 16:12 |显示全部楼层
呵呵 高技术呀' T9 J) `* X4 H( ]
好贴自然会顶
回复

使用道具 举报

主题

好友

43

积分

新兵上阵

该用户从未签到

发表于 2010-12-9 23:13 |显示全部楼层
呵呵 高技术呀: ~7 _# x0 f! {& k
好贴自然会顶
回复

使用道具 举报

主题

好友

2

积分

预备兵

该用户从未签到

发表于 2010-12-16 23:38 |显示全部楼层
希望看得懂
回复

使用道具 举报

主题

好友

2756

积分

少校

签到天数: 122 天

[LV.7]常住居民III

发表于 2010-12-16 23:47 |显示全部楼层
来学习一下,:)
回复

使用道具 举报

主题

好友

2756

积分

少校

签到天数: 122 天

[LV.7]常住居民III

发表于 2010-12-16 23:47 |显示全部楼层
来学习一下,看看:)
回复

使用道具 举报

主题

好友

522

积分

中尉

该用户从未签到

发表于 2010-12-18 00:00 |显示全部楼层
又是一个超高的技术贴呀。我这些PT可以活了。  Q7 z0 S/ p3 o  h+ A7 n1 r
可是关键是没有这么多资源的。。。
回复

使用道具 举报

主题

好友

8471

积分

中校

该用户从未签到

发表于 2010-12-20 09:27 |显示全部楼层
UP一下,看了半天,总算看懂了
回复

使用道具 举报

主题

好友

24

积分

新兵上阵

该用户从未签到

发表于 2010-12-22 20:49 |显示全部楼层
+++++++++++++++++++
回复

使用道具 举报

主题

好友

6

积分

预备兵

该用户从未签到

发表于 2010-12-24 15:36 |显示全部楼层
\貌似不错   学习一下· ··
回复

使用道具 举报

主题

好友

5

积分

预备兵

该用户从未签到

发表于 2010-12-25 13:21 |显示全部楼层
不错噢好好看一下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入

本版积分规则

Archiver| 手机版| 中国无线门户 ( 粤ICP备11076993 ) |网站地图 

GMT+8, 2018-7-23 07:59

Powered by Discuz! X3.4

© 2003-2013 广州威思信息科技有限公司

返回顶部 返回列表